Troubleshooting the WebRTC results

    This article describes all the possible errors that can occur during the WebRTC process and provides instructions on how to resolve them.


    TABLE OF CONTENTS

    Before the WebRTC test started

    If the test does not start because one of the following messages appears:

    • Failed to access your computer's camera and microphone (NotReadableError: Could not start audio source):


      Cause
      : Failure to start the microphone scan may be caused by a microphone usage restriction in the antivirus.

      Resolution
      :

    The result of the WebRTC test

    A successful check look as shown in the screenshot below.


    Microphone

    In the microphone section, only Audio capture is checked. It verifies the microphone connection and the ability to record sound from it. 

    Clicking on Audio capture gives more detailed information. This includes the device being tested, the number of audio channels and their volume.


    Potential errors in this section:

    • [ FAILED ] No active input channels detected. Microphone is most likely muted or broken, please check if muted in the sound settings or physically on the device. Then rerun the test.

      Cause
      : The microphone is muted or the wrong microphone is selected.

      Resolution
    • [ FAILED ] Microphone input level is low, increase input volume or move closer to the microphone.

      Cause
      : The microphone volume is low, and this error is accompanied by information about peaks:
      [ INFO ] Channel 0 levels: -56.3 dB (peak), -65.2 dB (RMS)

      Resolution
      :
    • [ FAILED ] Failed to get access to local media due to error: NotReadableError

      Cause
      : The selected device cannot be accessed.

      Resolution
      : If it's an external device, make sure it is connected to your computer or connect it to a different USB port.
    • [ FAILED ] Failed to get access to local media due to error: NotFoundError

      Cause
      : The device is physically disconnected or systemically disabled. This may also be displayed as shown in the user screenshot where the audio sourse is missing to test.


      Resolution
      : If it's an external device, make sure it is connected to your computer or connect it to a different USB port.

    Camera

    In the camera section, the camera resolution is checked starting from 640x360, along with its connection and supported camera resolutions.

    Possible errors in this section include:

    • [FAILED] Video track ended, camera stopped working.

      Cause
      : During the check, the camera stopped functioning.

      Resolution
      : If it's an external device, make sure it is connected to your computer or connect it to a different USB port.
    • [FAILED] getUserMedia failed with error: NotFoundError

      Cause
      : The camera is physically not connected or disabled in the device manager on the computer. This may also be displayed as shown in the user screenshot where the video source is missing to test.


      Resolution
      : If it's an external device, make sure it is connected to your computer or connect it to a different USB port.
    • If the camera resolution is lower than the one being checked, there will also be an error. The detailed description shows the user's camera resolution.

    Network

    In this section, parameters such as UDP enabled, TCP enabled, and WebSockets enabled are tested. In all cases, the result should be positive.

    WebSockets is a technology that enables establishing a persistent bidirectional network connection between the user's browser and the server.

    UDP/TCP are key components of network protocols and data transmission.

    Possible errors in this section include:

    • Udp enabled
      [ FAILED ] Failed to gather specified candidates
    • Tcp enabled
      [ FAILED ] Failed to gather specified candidates
    • Websockets enabled
      [ FAILED ] Websockets not supported.
      [ FAILED ] Failed to connect to Websockets Server.

    Cause: Blocking of required ports on the device by anti-virus software, network firewall, firewall or other security measures.

    Resolution
    :

    Connectivity

    In this section, the search for a STUN server is conducted. The 'Relay connectivity' item must pass successfully. 

    The issues that can result in a negative test result are similar to those in the "Network" section, such as closed ports or corporate network restrictions. Typically, the test in this section fails in conjunction with the previous section.

     


    See also: