The system check is stuck in a loop

    This article provides instructions on how to solve the issue when the second step is stuck in a loop.

    Symptoms 

    Unable to start the exam because the system check has failed. The system has failed to retrieve image data from the webcam.

    The problem is shown in the screenshot below.

    Causes

    The webcam image is being intercepted or accessed by other programs running on your computer, preventing it from being detected during the system check.

    Resolution

    • Disable any programs that can access your webcam (such as Skype, Discord, TeamViewer, Zoom, etc.). These programs may be using the webcam, causing conflicts with the system check. Refer to the following article for instructions on how to close all applications that can capture webcam/microphone/screen?
    • Close any other browser tabs that might be using the webcam at the same time. Having multiple tabs accessing the webcam simultaneously can cause issues.
    • Allow access to the webcam in the OS settings. Check the webcam permissions in the OS settings (Windows or macOS) and ensure that access to the webcam is allowed.
    • Temporarily turn off your antivirus software for the duration of the exam. Antivirus programs may interfere with the webcam and prevent it from functioning properly during the system check. Refer to the following article for instructions on how to turn off build-in OS Firewall

    After performing these steps, attempt to run the system check again to determine if the webcam is now providing a proper image.