No access to the screen or Endless "Choose what to share"

This article provides instructions on how to solve the issue when the error message "No access to the screen" appears.

Symptoms 

Unable to start the exam because the preparation has failed. The system has detected that there is no access to the screen.

The problem is shown in the screenshot below.
ConstructorProctor_NoScreenAccess

Causes

Access to screen recording is disabled in the OS settings. As a result, you are constantly asked to share your screen.

Resolution

  1. Go to the Apple Menu > System Settings > Privacy & Security Screen Recording.
  2. Make sure that your microphone can be accessed by browsers or the Constructor app if you are using it:MacOSPrivacyScreenrecording (1)Note: If these settings are grayed out, you must allow changing them first. Click on the lock icon at the bottom of the window to unlock the settings. You will be prompted to enter your administrator name and password.
  3. After making all the changes, restart your browser and open the exam.

See also: