Unable to submit webform even when all required fields are filled
Symptoms
When trying to submit a webform, the Submit button does not work even though all required fields are completed correctly.
Cause
This issue may occur if cached data in the browser prevents the form from validating the fields properly.
Resolution
Clear your browser cache and try submitting the webform again.
Google Chrome
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Open Chrome.
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Click the three-dot menu (⋮) in the top right.
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Go to Settings > Privacy and security > Clear browsing data.
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In the pop-up, select Cookies and other site data and Cached images and files.
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Choose All time for the time range.
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Click Clear data and restart Chrome.
Official Google instructions.
Microsoft Edge
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Open Edge.
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Click the three-dot menu (⋮) in the top right.
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Go to Settings > Privacy, search, and services.
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Under Clear browsing data, click Choose what to clear.
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Select Cookies and other site data and Cached images and files.
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Choose All time for the time range.
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Click Clear now and restart Edge.
Official Microsoft instructions.
Safari (Mac)
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Open Safari.
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In the menu bar, click Safari > Settings (Preferences).
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Go to the Privacy tab.
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Click Manage Website Data.
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Select Remove All to clear cookies and cached files.
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Confirm and restart Safari.
Detailed guide from Macworld.
Additional Notes
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If clearing the cache does not resolve the issue, try submitting the form in an incognito/private browser window.
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Make sure you are using the latest version of your browser.